Home »

Mariadb Replication

Страница 1 / 2

alekperov11
Сообщения: 6
Topic starter
(@alekperov11)
Младший сисадмин
Присоединился: 2 года назад

Привет

У меня установлены mariadb104-server-10.4.6 galera: 25.3.26 FreeBSD 12
Это мой my.cnf.

root@freebsd:/usr/local/etc # nano my.cnf
[mysqld]
binlog_format=ROW
default-storage-engine=innodb
innodb_autoinc_lock_mode=2
bind-address=0.0.0.0

# Galera Provider Configuration
wsrep_on=ON
wsrep_provider=/usr/local/lib/libgalera_smm.so

# Galera Cluster Configuration
wsrep_cluster_name="test_cluster"
wsrep_cluster_address="gcomm://192.168.64.143,192.168.64.144"

# Galera Synchronization Configuration
wsrep_sst_method=rsync

# Galera Node Configuration
wsrep_node_address="this_node_ip"
wsrep_node_name="this_node_name"

У меня выскакивает это ошибка когда хочу запустить mariadb.
root@freebsd:/usr/local/etc # service mysql-server start --wsrep-new-cluster
/usr/local/etc/rc.d/mysql-server: ERROR: --wsrep-new-cluster not found in mysql_instances

Пожалуйста помогите мне. Что я должен делать?

Ответить
Метки темы
9 Ответов
STALKER_SLX
Сообщения: 200
(@stalker_slx)
Devops
Присоединился: 2 года назад

1. Вы пытаетесь запустить свежеустановленный кластер? Или он уже работал до этого и произошёл какой-то сбой?!

2. Укажите что и как Вы делали, то есть по какому мануалу Вы настраивали Ваш кластер?

3. Если кластер уже был сформирован и работал, тогда команда для его запуска будет совсем иной!!! Читаем тут:

«Use the --wsrep-new-cluster argument only when initializing the Primary Component. Don’t use it to connect a new node to an existing cluster.»

https://galeracluster.com/library/training/tutorials/starting-cluster.html

Вот тут описаны процедуры для обслуживания кластера «Galera»:

https://docs.openstack.org/openstack-ansible/rocky/admin/maintenance-tasks/galera.html

А тут описана схожая проблема:

http://qaru.site/questions/996086/mariadb-galera-cluster-set-up-problems

Ответить
alekperov11
Сообщения: 6
Topic starter
(@alekperov11)
Младший сисадмин
Присоединился: 2 года назад

Спасибо.

Сейчас все пролистаю, результат скажу.

Ответить
alekperov11
Сообщения: 6
Topic starter
(@alekperov11)
Младший сисадмин
Присоединился: 2 года назад

Свежеустановленный до этого не работал.

Да просто установил mariadb он сам установил галеру и все накрутил my.cnf и запустил.

Никакой инструкции.

my.conf 1 нод

[mariadb]
binlog_format=ROW
default-storage-engine=innodb
innodb_autoinc_lock_mode=2
bind-address=0.0.0.0

# Galera Provider Configuration
wsrep_on=ON
wsrep_provider=/usr/local/lib/libgalera_smm.so

# Galera Cluster Configuration
wsrep_cluster_name="test_cluster"
wsrep_cluster_address="gcomm://192.168.64.145,192.168.64.146"

# Galera Synchronization Configuration
wsrep_sst_method=rsync

# Galera Node Configuration
wsrep_node_address="192.168.64.144"
wsrep_node_name="this_node_name"

log-error=/var/db/mysql/mysqld.log
#slow-query-log-file = /var/db/mysql/mysql-slow.log

если запустить так

root@freebsd:/home/akshin # service mysql-server start --wsrep-new-cluster
/usr/local/etc/rc.d/mysql-server: ERROR: --wsrep-new-cluster not found in mysql_instances

если запустить так 

root@freebsd:/home/akshin # service mysql-server start

то mariadb не запускается и и вот такой лог

root@freebsd:/home/akshin # cat /var/db/mysql/mysqld.log
2019-08-07 17:22:00 0 [Note] WSREP: Read nil XID from storage engines, skipping position init
2019-08-07 17:22:00 0 [Note] WSREP: wsrep_load(): loading provider library '/usr/local/lib/libgalera_smm.so'
2019-08-07 17:22:00 0 [Note] WSREP: wsrep_load(): Galera 3.26(rrelease_25.3.26) by Codership Oy <info@codership.com> loaded successfully.
2019-08-07 17:22:00 0 [Note] WSREP: CRC-32C: using hardware acceleration.
2019-08-07 17:22:00 0 [Note] WSREP: Found saved state: 00000000-0000-0000-0000-000000000000:-1, safe_to_bootstrap: 1
2019-08-07 17:22:00 0 [Note] WSREP: Passing config to GCS: base_dir = /var/db/mysql/; base_host = 192.168.64.144; base_port = 4567; cert.log_conflicts = no; cert.optimistic_pa = yes; debug = no; evs.auto_evict = 0; evs.delay_margin = PT1S; evs.delayed_keep_period = PT30S; evs.inactive_check_period = PT0.5S; evs.inactive_timeout = PT15S; evs.join_retrans_period = PT1S; evs.max_install_timeouts = 3; evs.send_window = 4; evs.stats_report_period = PT1M; evs.suspect_timeout = PT5S; evs.user_send_window = 2; evs.view_forget_timeout = PT24H; gcache.dir = /var/db/mysql/; gcache.keep_pages_size = 0; gcache.mem_size = 0; gcache.name = /var/db/mysql//galera.cache; gcache.page_size = 128M; gcache.recover = no; gcache.size = 128M; gcomm.thread_prio = ; gcs.fc_debug = 0; gcs.fc_factor = 1.0; gcs.fc_limit = 16; gcs.fc_master_slave = no; gcs.max_packet_size = 64500; gcs.max_throttle = 0.25; gcs.recv_q_hard_limit = 9223372036854775807; gcs.recv_q_soft_limit = 0.25; gcs.sync_donor = no; gmcast.segment = 0; gmcast.version = 0; pc.announce_timeout = PT3S;
2019-08-07 17:22:00 0 [Note] WSREP: GCache history reset: 00000000-0000-0000-0000-000000000000:0 -> 00000000-0000-0000-0000-000000000000:-1
2019-08-07 17:22:00 0 [Note] WSREP: Assign initial position for certification: -1, protocol version: -1
2019-08-07 17:22:00 0 [Note] WSREP: wsrep_sst_grab()
2019-08-07 17:22:00 0 [Note] WSREP: Start replication
2019-08-07 17:22:00 0 [Note] WSREP: Setting initial position to 00000000-0000-0000-0000-000000000000:-1
2019-08-07 17:22:00 0 [Note] WSREP: protonet asio version 0
2019-08-07 17:22:00 0 [Note] WSREP: Using CRC-32C for message checksums.
2019-08-07 17:22:00 0 [Note] WSREP: backend: asio
2019-08-07 17:22:00 0 [Note] WSREP: gcomm thread scheduling priority set to other:0
2019-08-07 17:22:00 0 [Warning] WSREP: access file(/var/db/mysql//gvwstate.dat) failed(No such file or directory)
2019-08-07 17:22:00 0 [Note] WSREP: restore pc from disk failed
2019-08-07 17:22:00 0 [Note] WSREP: GMCast version 0
2019-08-07 17:22:00 0 [Note] WSREP: (569929f9, 'tcp://0.0.0.0:4567') listening at tcp://0.0.0.0:4567
2019-08-07 17:22:00 0 [Note] WSREP: (569929f9, 'tcp://0.0.0.0:4567') multicast: , ttl: 1
2019-08-07 17:22:00 0 [Note] WSREP: EVS version 0
2019-08-07 17:22:00 0 [Note] WSREP: gcomm: connecting to group 'test_cluster', peer '192.168.64.145:,192.168.64.146:'
2019-08-07 17:22:03 0 [Warning] WSREP: no nodes coming from prim view, prim not possible
2019-08-07 17:22:03 0 [Note] WSREP: view(view_id(NON_PRIM,569929f9,1) memb {
569929f9,0
} joined {
} left {
} partitioned {
})
2019-08-07 17:22:04 0 [Warning] WSREP: last inactive check more than PT1.5S ago (PT3.7111S), skipping check

My.cnf нод 2

root@freebsd:/home/akshin # nano /usr/local/etc/my.cnf
GNU nano 4.2 /usr/local/etc/my.cnf
[mariadb]
binlog_format=ROW
default-storage-engine=innodb
innodb_autoinc_lock_mode=2
bind-address=0.0.0.0

# Galera Provider Configuration
wsrep_on=ON
wsrep_provider=/usr/local/lib/libgalera_smm.so

# Galera Cluster Configuration
wsrep_cluster_name="test_cluster"
wsrep_cluster_address="gcomm://192.168.64.144"

# Galera Synchronization Configuration
wsrep_sst_method=rsync

# Galera Node Configuration
wsrep_node_address="192.168.64.145"
wsrep_node_name="this_node_name2"

log-error=/var/db/mysql/mysqld.log
#slow-query-log-file = /var/db/mysql/mysql-slow.log

My.cnf нод 3 root@freebsd:/home/akshin # nano /usr/local/etc/my.cnf
GNU nano 4.2 /usr/local/etc/my.cnf
[mariadb]
binlog_format=ROW
default-storage-engine=innodb
innodb_autoinc_lock_mode=2
bind-address=0.0.0.0

# Galera Provider Configuration
wsrep_on=ON
wsrep_provider=/usr/local/lib/libgalera_smm.so

# Galera Cluster Configuration
wsrep_cluster_name="test_cluster"
wsrep_cluster_address="gcomm://192.168.64.144"

# Galera Synchronization Configuration
wsrep_sst_method=rsync

# Galera Node Configuration
wsrep_node_address="192.168.64.146"
wsrep_node_name="this_node_name3"

log-error=/var/db/mysql/mysqld.log
#slow-query-log-file = /var/db/mysql/mysql-slow.log
Ответить
alekperov11
Сообщения: 6
Topic starter
(@alekperov11)
Младший сисадмин
Присоединился: 2 года назад

Как победить  ERROR: --wsrep-new-cluster not found in mysql_instances

Freebsd 12 mariadb103-server-10.3.16

Ответить
Страница 1 / 2