Home »

Установка и запуск ...
 

Установка и запуск Synapse (статья: Настройка чат сервера Matrix Synapse и клиента Riot)  


Александр
Сообщения: 149
(@dyuk)
Devops
Присоединился: 4 года назад

Возникли проблемы с запуском сервера Matrix Synapse. Статья наверно маленько устарела, c Python2.7 synapse ставиться не захотел, поставил 3.6
Начало проблем: "Создаем виртуальную среду для приложения synapse" (скрин), ну и далее... по нарастающей. Сам сервер не запускается конечно.
Пару лет назад с Python2.7 всё получилось классно, даже запустил в одной конторе, а сейчас возникла проблема на новом сервере и ... тупик. Подскажите пож-та пути решения, или может актуализировать статью? Но эт наверно не сразу, а надо как обычно - вчера...

Ответить
3 Ответов
Zerox
Сообщения: 599
Admin
(@zerox)
Honorable Member
Присоединился: 7 лет назад

Я не проверял эту статью давно. Если надо быстро запустить и некогда разбираться, можно взять питон 2.7 и поставить на нем. 

Ответить
Александр
Сообщения: 149
(@dyuk)
Devops
Присоединился: 4 года назад

Дело в том, что на 2.7 не захотел ставиться synapse, видимо тоже обновился, а где загрузить ту версию, которая работает с 2.7 не нашёл. Может подскажите откуда взять и как правильно установить из пакета?

Ответить
Александр
Сообщения: 149
(@dyuk)
Devops
Присоединился: 4 года назад

Проблема с установкой synapse на centos8 с питоном 3.6 решена. Делал по этой статье:
https://www.informaticar.net/install-matrix-synapse-on-centos-8/
Тока опять затык вышел, этап из вашей статьи:

Установим еще несколько пакетов, необходимых для взаимодействия synapse с postgresql.

# yum install postgresql-devel libpqxx-devel.x86_64

Пишет так:

Error:
Problem: cannot install the best candidate for the job
- package postgresql13-devel-13.0-1PGDG.rhel8.x86_64 requires postgresql13(x86-64) = 13.0-1PGDG.rhel8, but none of the providers can be installed
- package postgresql12-devel-12.4-1PGDG.rhel8.x86_64 requires postgresql12(x86-64) = 12.4-1PGDG.rhel8, but none of the providers can be installed
- package postgresql11-devel-11.9-1PGDG.rhel8.x86_64 requires postgresql11(x86-64) = 11.9-1PGDG.rhel8, but none of the providers can be installed
- package postgresql10-devel-10.14-1PGDG.rhel8.x86_64 requires postgresql10(x86-64) = 10.14-1PGDG.rhel8, but none of the providers can be installed
- package postgresql96-devel-9.6.19-1PGDG.rhel8.x86_64 requires postgresql96(x86-64) = 9.6.19-1PGDG.rhel8, but none of the providers can be installed
- package postgresql95-devel-9.5.23-1PGDG.rhel8.x86_64 requires postgresql95(x86-64) = 9.5.23-1PGDG.rhel8, but none of the providers can be installed
- package postgresql13-13.0-1PGDG.rhel8.x86_64 is filtered out by modular filtering
- package postgresql12-12.4-1PGDG.rhel8.x86_64 is filtered out by modular filtering
- package postgresql11-11.9-1PGDG.rhel8.x86_64 is filtered out by modular filtering
- package postgresql10-10.14-1PGDG.rhel8.x86_64 is filtered out by modular filtering
- package postgresql96-9.6.19-1PGDG.rhel8.x86_64 is filtered out by modular filtering
- package postgresql95-9.5.23-1PGDG.rhel8.x86_64 is filtered out by modular filtering
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

ну соответственно не хочет работать с базой psycopg2.
С бд, которая по умолчанию (sqlite3), всё запустилось. Кстати, а в чём преимущества postgresql ? И как обойти этот затык?, что за пакеты надо доставить? Установлена версия postgres (PostgreSQL) 10.14...

Ответить