Home » Форум

Форум

не открывается web ...
 

[Решено] не открывается web интерфейс  

 

GoProg
(@goprog)
Active Member
Присоединился: 1 месяц назад
Сообщения: 6
21.08.2019 09:57  

Всем добрый день

Не открывается web интерфейс, белая страница.

proxmox-ve: 5.2-2 (running kernel: 4.15.17-1-pve)
pve-manager: 5.2-1 (running version: 5.2-1/0fcd7879)

очистка кэша браузера, другие браузеры та же картина

systemctl restart pveproxy - без результата

# netstat -an | grep 8006
tcp 0 0 0.0.0.0:8006 0.0.0.0:* LISTEN

ssh работает, виртуальные машины работают, мобильная версия открывается


Цитата
STALKER_SLX
(@stalker_slx)
Estimable Member
Присоединился: 10 месяцев назад
Сообщения: 122
21.08.2019 11:05  

@goprog

Для начала попробуйте в браузере ввести IP-адрес Вашего proxmox вместо DNS-имени, чтобы получилось так (192.168.10.152 замените на свой IP-адрес):

https://192.168.10.152:8006


ОтветитьЦитата
STALKER_SLX
(@stalker_slx)
Estimable Member
Присоединился: 10 месяцев назад
Сообщения: 122
21.08.2019 11:25  

@goprog

Если Вы не установили на свой proxmox сертификат - купленный или выпущенный своими силами и добавлен на Ваш компьютер в корневые сертификаты, то в браузере "Opera" появится сообщение :аше подключение не является приватным. Не удалось подтвердить, что это сервер. Операционная система компьютера не доверяет его сертификату безопасности. Возможно, сервер настроен неправильно или кто-то пытается перехватить ваши данные. NET:ERR_CERT_AUTHORITY_INVALID".

Дальше у Вас будет две кнопки "Не продолжать" и "Помогите мне разобраться" - нажимаем вторую., а потом - "Перейти к 192.168.10.152 (небезопасно)"

Ну, а дальше уже Вас встретить знакомый Вам веб-интерфейс proxmox, где нужно вводить свои данные для авторизации - логин и пароль.

Если Вы используете иной браузер, то текст приведённого выше сообщения может быть другим, но суть и действия будут такими же.


ОтветитьЦитата
GoProg
(@goprog)
Active Member
Присоединился: 1 месяц назад
Сообщения: 6
21.08.2019 11:32  

@stalker_slx

это все мне известно, инсталляция не новая уже работала около года


ОтветитьЦитата
STALKER_SLX
(@stalker_slx)
Estimable Member
Присоединился: 10 месяцев назад
Сообщения: 122
21.08.2019 11:41  
От: @goprog

@stalker_slx

это все мне известно, инсталляция не новая уже работала около года

1. Тогда показывайте логи Вашего proxmox

2. С других компьютеров сети такая же ситуация?

3. Какие у Вас правила в файерволе - доступ к proxmox через браузер только с определённого IP или что-то иное?!

This post was modified 1 месяц назад by STALKER_SLX

ОтветитьЦитата
GoProg
(@goprog)
Active Member
Присоединился: 1 месяц назад
Сообщения: 6
21.08.2019 11:47  

@stalker_slx

какие именно?

вот например access.log

[21/08/2019:10:07:43 +0300] "GET / HTTP/1.1" 200 754
[21/08/2019:10:07:43 +0300] "GET /pve2/ext6/crisp/resources/charts-all.css HTTP/1.1" 200 995
[21/08/2019:10:07:43 +0300] "GET /pve2/ext6/theme-crisp/resources/theme-crisp-all.css HTTP/1.1" 200 68
[21/08/2019:10:07:43 +0300] "GET /pve2/js/pvemanagerlib.js?ver=5.2-1 HTTP/1.1" 304 -
[21/08/2019:10:07:43 +0300] "GET /pve2/ext6/locale/locale-en.js HTTP/1.1" 304 -
[21/08/2019:10:07:43 +0300] "GET /pve2/ext6/ext-all.js HTTP/1.1" 304 -
[21/08/2019:10:07:43 +0300] "GET /pve2/css/ext6-pve.css?ver=5.2-1 HTTP/1.1" 200 2814
[21/08/2019:10:07:43 +0300] "GET /pve2/fa/css/font-awesome.css HTTP/1.1" 200 7289
[21/08/2019:10:07:43 +0300] "GET /pve2/ext6/charts.js HTTP/1.1" 304 -
[21/08/2019:10:07:43 +0300] "GET /proxmoxlib.js?ver=1.0-18 HTTP/1.1" 304 -
[21/08/2019:10:07:44 +0300] "GET /pve2/ext6/theme-crisp/resources/theme-crisp-all_1.css HTTP/1.1" 200 33744
[21/08/2019:10:07:44 +0300] "GET /pve2/ext6/theme-crisp/resources/theme-crisp-all_2.css HTTP/1.1" 200 5208
[21/08/2019:10:07:44 +0300] "GET /pve2/images/logo-128.png HTTP/1.1" 200 4977
[21/08/2019:10:07:44 +0300] "GET /pve2/images/logo-128.png HTTP/1.1" 200 4977
[21/08/2019:10:07:44 +0300] "GET /PVE/StdWorkspace.js?_dc=1566371245735 HTTP/1.1" 501 -
[21/08/2019:10:07:55 +0300] "GET / HTTP/1.1" 200 754
[21/08/2019:10:07:55 +0300] "GET /pve2/ext6/theme-crisp/resources/theme-crisp-all.css HTTP/1.1" 200 68
[21/08/2019:10:07:55 +0300] "GET /pve2/ext6/theme-crisp/resources/theme-crisp-all_1.css HTTP/1.1" 200 33744
[21/08/2019:10:07:55 +0300] "GET /pve2/ext6/crisp/resources/charts-all.css HTTP/1.1" 200 995
[21/08/2019:10:07:55 +0300] "GET /pve2/fa/css/font-awesome.css HTTP/1.1" 200 7289
[21/08/2019:10:07:55 +0300] "GET /pve2/css/ext6-pve.css?ver=5.2-1 HTTP/1.1" 200 2814
[21/08/2019:10:07:55 +0300] "GET /pve2/ext6/locale/locale-en.js HTTP/1.1" 200 2569
[21/08/2019:10:07:55 +0300] "GET /pve2/ext6/theme-crisp/resources/theme-crisp-all_2.css HTTP/1.1" 200 5208
[21/08/2019:10:07:55 +0300] "GET /pve2/js/pvemanagerlib.js?ver=5.2-1 HTTP/1.1" 200 152085
[21/08/2019:10:07:55 +0300] "GET /pve2/ext6/ext-all.js HTTP/1.1" 200 609692
[21/08/2019:10:07:55 +0300] "GET /pve2/ext6/charts.js HTTP/1.1" 200 100383
[21/08/2019:10:07:55 +0300] "GET /proxmoxlib.js?ver=1.0-18 HTTP/1.1" 200 41451
[21/08/2019:10:07:56 +0300] "GET /pve2/images/logo-128.png HTTP/1.1" 200 4977
[21/08/2019:10:07:56 +0300] "GET /PVE/StdWorkspace.js?_dc=1566371257492 HTTP/1.1" 501 -
[21/08/2019:10:29:28 +0300] "GET / HTTP/1.1" 200 754
[21/08/2019:10:29:29 +0300] "GET /pve2/ext6/theme-crisp/resources/theme-crisp-all.css HTTP/1.1" 200 68
[21/08/2019:10:29:30 +0300] "GET /PVE/StdWorkspace.js?_dc=1566372550774 HTTP/1.1" 501 -

в принципе я это и так вижу в developers tools браузера, всё заканчивается так:

501 no such file '/PVE/StdWorkspace.js'


ОтветитьЦитата
STALKER_SLX
(@stalker_slx)
Estimable Member
Присоединился: 10 месяцев назад
Сообщения: 122
21.08.2019 12:03  

@goprog

Похоже, что у Вашего proxmox некоторые системные файлы повреждены - попробуйте в его консоли (через SSH) обновить систему:

apt update && apt upgrade

А потом исправить все зависимости пакетов:

apt install -f

This post was modified 1 месяц назад by STALKER_SLX

ОтветитьЦитата
STALKER_SLX
(@stalker_slx)
Estimable Member
Присоединился: 10 месяцев назад
Сообщения: 122
21.08.2019 12:27  

Если проблема останется, тогда выполните в терминале последовательно три команды:

apt dist-upgrade

pvecm updatecerts --force

service pveproxy restart

This post was modified 1 месяц назад 3 times by STALKER_SLX

ОтветитьЦитата
GoProg
(@goprog)
Active Member
Присоединился: 1 месяц назад
Сообщения: 6
21.08.2019 12:48  

без изменений


ОтветитьЦитата
STALKER_SLX
(@stalker_slx)
Estimable Member
Присоединился: 10 месяцев назад
Сообщения: 122
21.08.2019 13:30  

А что у Вас с сертификатами? Сюда смотрели:

https://pve.proxmox.com/wiki/HTTPS_Certificate_Configuration_(Version_4.x,_5.0_and_5.1)#Revert_to_default_configuration


ОтветитьЦитата
GoProg
(@goprog)
Active Member
Присоединился: 1 месяц назад
Сообщения: 6
21.08.2019 13:30  

в /etc/apt/sources.list добавил deb http://download.proxmox.com/debian/pve stretch pve-no-subscription

(у меня было только deb http://security.debian.org stretch/updates main contrib)

затем

#apt update && apt dist-upgrade
#service pveproxy restart

морда поднялась


ОтветитьЦитата
GoProg
(@goprog)
Active Member
Присоединился: 1 месяц назад
Сообщения: 6
21.08.2019 13:32  

ну и апнулся соответственно до

proxmox-ve: 5.4-2 (running kernel: 4.15.17-1-pve)
pve-manager: 5.4-13 (running version: 5.4-13/aee6f0ec)


ОтветитьЦитата
Share:

Пожалуйста, Вход или Зарегистрироваться