Home » Mikrotik » Как настроить микротик routerboard RB951G-2HnD

Как настроить микротик routerboard RB951G-2HnD

Продолжаю рассказ про замечательную серию устройств из Латвии, которые зарекомендовали себя как функциональные и надежные девайсы. В данной статье я подробно рассмотрю вопрос базовой настройки роутеров mikrotik на примере бюджетной и самой популярной модели RB951G-2HnD. Данная инструкция подойдет практически к любой модели, так как все они сделаны на базе одной и той же операционной системы.

Если у вас есть желание научиться работать с роутерами микротик и стать специалистом в этой области, рекомендую пройти курсы по программе, основанной на информации из официального курса MikroTik Certified Network Associate. Все подробности читайте ниже.

Введение

Роутеры Mikrotik routerboard достаточно давно появились на рынке, но так до сих пор и не завоевали большую популярность. Хотя свою нишу заняли. Лично я считаю, что это отличный роутер для дома, по надежности у него нет конкурентов. Это действительно маршрутизатор, который можно один раз настроить и забыть. Лично мне еще ни разу не попадалось устройство, которое бы приходилось принудительно перезагружать, чтобы вывести его из комы, как это часто бывает с другими бюджетными железками.

Распространение среди домашних пользователей сдерживает в первую очередь сложность настройки. И хотя более ли менее продвинутому пользователю может показаться, что ничего тут сложного нет. Но на самом деле есть. И я часто сталкивался с просьбами настроить роутер дома для раздачи интернета по wifi, так как купившие по чьей-нибудь рекомендации пользователи сами не могли полностью настроить нужный функционал, хотя инструкций в интернете хватает.

Этот пробел я хочу восполнить и написать подробную пошаговую инструкцию по настройке микротика с нуля для чайников на примере самой подходящей для дома модели RB951G-2HnD. У меня давно подготовлена личная шпаргалка в виде текстового файла. По ней я буквально за 10 минут настраиваю роутер и отдаю пользователю. То есть реально ничего сложного нет, если знаешь, что делаешь. На основе этой шпаргалки я и напишу материал.

Возможно опытному пользователю нечего будет тут почерпнуть, а может быть я сам что-то делаю не совсем правильно или не оптимально. Прошу сделать подсказку или замечание в комментарии, если это действительно так. Я пишу статьи в том числе и для того, чтобы самому научиться чему-то новому. Как гласит одна восточная мудрость — чтобы получить новые знания, нужно поделиться теми, что есть у тебя с другими. Именно этим я и занимаюсь на страницах данного сайта.

Описание Mikrotik RB951G-2HnD

Вот он, герой сегодняшней статьи — Mikrotik RB951G-2HnD. Его описание, отзывы и стоимость можно быстро проверить на Яндекс.Маркете. По количеству отзывов уже можно сделать вывод об определенной популярности этого роутера.

Внешний вид устройства.

Mikrotik RB951G-2HnD

Важной особенностью этого роутера, которой лично я активно пользуюсь, является возможность запитать его с помощью специального poe адаптера.

MikroTik Gigabit PoE адаптер

На изображении он справа. Берется стандартный блок питания от роутера и poe адаптер. Блок питания подключается к адаптеру, а от адаптера уже идет патч корд в первый порт routerboard. Маршрутизатор можно повесить на стену в любое место, нет необходимости привязываться к розетке. Сразу отмечу, что запитать роутер можно только poe адаптером микротика. У него другой стандарт и привычные poe свитчи 802.3af не подойдут.

Существует похожая модель RB951Ui-2HnD. Она отличается от описываемой мной только тем, что у нее 100Mb порт, а у RB951G-2HnD 1Gb. Если для вас эти отличия не принципиальны, то можете покупать более дешевую модель. В остальном они идентичны.

Будем потихонечку двигаться дальше. Как проще всего настроить микротик? Я для этого использую стандартную утилиту winbox. Можно пользоваться и web интерфейсом, но лично мне намного удобнее winbox. Так что для продолжения настройки скачивайте ее на компьютер.

Сброс настроек роутера

Подключаем роутер к сети, подаем питание и запускаем на компьютере winbox. Переходим на вкладку Neighbors и ждем, когда утилита найдет наш микротик. Это может занять какое-то время. На всякий случай можно нажать Refresh, если роутер долго не обнаруживается.

подключение через winbox

Нажимаем на мак адрес устройства, он должен будет скопироваться в поле Connect To. Пароль по-умолчанию для входа в роутеры mikrotik — пустой, а пользователь — admin. Вводим имя пользователя, поле с паролем оставляем не заполненным. Нажимаем connect. Нас встречает информационное окно, в котором приведено описание стандартных настроек.

сброс настроек по-умолчанию

Здесь их можно либо оставить, либо удалить. Я всегда удаляю, так как стандартные настройки чаще всего не подходят под конкретную ситуацию. Приведу несколько примеров, почему это так:

  1. Я запитал свой роутер по первому порту через poe адаптер и поэтому вынужден использовать этот порт как локальный. В настройках по-умолчанию этот порт используется как wan порт для получения интернета от провайдер.
  2. В настройках по-умолчанию установлено автоматическое получение настроек от провайдера по dhcp. Если у вас другой тип подключения, то вам стандартная настройка не подходит.
  3. По-умолчанию устанавливается адресное пространство 192.168.88.0/24. Мне лично не нравятся сетки по-умолчанию, так как если в них случайно воткнуть новое устройство, где будет так же забит умолчательный адрес, то в сети начнутся проблемы. Дома может это и не актуально, но в коммерческих организациях мне приходилось с этим сталкиваться. Поэтому я на всякий случай сетку всегда меняю.

Так что мы нажимаем Remove Configuration, чтобы удалить настройки. После этого роутер перезагрузится. Ждем примерно минуту и подключаемся к нему снова.

Если вы по какой-то причине не удалили сразу предустановки, то выполнить сброс настроек в mikrotik на заводские можно позже. Для этого надо в терминале набрать сначала system, а затем reset. У вас спросят подтверждение и после этого routerboard перезагрузится с заводскими настройками.

Обновление прошивки

После очистки настроек я рекомендую сразу выполнить обновление прошивки роутера Mikrotik. Для этого идем в раздел Download официального сайта и скачиваем нужный файл. В данном случае это платформа mipsbe, пакет для загрузки Main package. Загружаем его на компьютер и подключаемся к роутеру с помощью winbox. Выбираем слева раздел Files. Затем открываем рядом два окна — один с файлом прошивки, второй с winbox и перетаскиваем мышкой файл из папки в winbox в список файлов.

обновление прошивки mikrotik

Дожидаемся окончания загрузки прошивки и перезагружаем микротик через раздел меню System -> Reboot. Прошивка обновится во время загрузки роутера. Подождать придется минуты 3. Поле этого снова подключаемся к устройству. После обновления прошивки, нужно обновить загрузчик. Делается это в пункте меню System — RouterBoard. Заходите туда, проверяете строки Current Firmware и Upgrade Firmware. Если они отличаются, то жмете кнопку Upgrade. Если одинаковые, то можно ничего не делать. Изменения вступят в силу после перезагрузки.

обновление firmware

Проверить версию установленной прошивки можно в разделе System — Packages.

проверка обновлений

В моем случае версия прошивки — 6.43.4. В будущем, когда на роутере будет настроен интернет, обновляться можно автоматически в этом разделе, нажимая на Check For Updates.

Прошивку обновили, можно приступать к настройке.

Объединение портов в бридж

Одной из особенностей роутеров mikrotik routerboard является отсутствие предустановленных настроек портов. Объясняю на пальцах, что это такое. Покупая обычный бюджетный роутер, вы увидите подписи к портам. На одном из них обязательно будет написано WAN, на других либо ничего не будет написано, либо LAN. То есть у вас уже будет один порт настроен определенным образом для подключения интернета и остальные порты будут объединены в switch для удобства подключения оборудования.

В Mikrotik не так. Там все порты равнозначны и WAN портом может стать абсолютно любой, какой пожелаете. Так как я 1-й порт использую для подключения питания, в качестве WAN у меня будет выступать 5-й порт. А все остальные я объединю в единую сеть с помощью bridge и добавлю к ним wifi интерфейс. Для этого идем в раздел Bridge и создаем новый bridge1.

Настройка bridge в Mikrotik

Настройки все оставляем дефолтные. У нас появился bridge1. Переходим на вкладку ports и жмем плюсик. Добавляем в brdige1 все порты, кроме WAN. В моем случае это 5-й порт.

добавление портов в bridge

Мы объединили все необходимые интерфейсы в бридж для организации единого пространства для всех подключенных устройств.

Настройка статического IP

До этого мы подключались к роутеру по МАК адресу. Сейчас можно ему назначить статический локальный ip адрес, по которому он будет доступен в сети. Для этого идем в раздел IP -> Addresses и жмем плюсик.

настройка статического ip в mikrotik

Указываете в разделе Address любую подсеть. Я выбрал 192.168.9.0. Соответственно микротику мы назначаем адрес  192.168.9.1/24. В качестве интерфейса выбираем bridge1. Поле Network можно не заполнять, оно заполнится автоматически. Теперь наш роутер доступен и по локальным интерфейсам, и по wifi (который еще предстоит настроить) по адресу 192.168.9.1.

Настройка интернета в микротик

Сейчас самое время подключиться к провайдеру и настроить интернет. Тут трудно охватить все возможные варианты подключения. Их может быть много. Я рассмотрю два самых популярных способа:

  1. Вы получаете настройки от провайдера автоматически по dhcp.
  2. Провайдер дал вам готовые настройки и вы их вводите вручную.

Как я уже писал ранее, для подключения к провайдеру мы будем использовать 5-й порт. Подключайте провод провайдера.

Для получения настроек по dhcp переходите в winbox в раздел IP -> DHCP Client и жмите плюсик. Выбираете интерфейс ether5 и жмете ОК.

получение настроек по dhcp

Если вы все сделали правильно, то увидите, какой IP адрес получили. В разделе IP -> Addresses будет информация о настройках.

информация об ip

Рассмотрим вариант, когда провайдер выдал все настройки и вам нужно самим их задать. Будем считать, что наши настройки интернета следующие:

IP адрес 192.168.1.104
Маска 255.255.255.0
Шлюз 192.168.1.1
DNS 192.168.1.1

Сначала укажем IP адрес. Делаем все то же самое, что и в предыдущем пункте при настройке статического IP. Только теперь вместо интерфейса bridge1 указываем ether5 и вводим соответствующий адрес — 192.168.1.104/24. Тут мы сразу указали и адрес и маску подсети.

установка ip провайдера

Дальше нам нужно установить шлюз по-умолчанию. Без этого обязательного шага интернет не заработает. Идем в раздел IP -> Routes и жмем плюсик для добавления шлюза по-умолчанию. В Dst. Address оставляем как есть 0.0.0.0/0, а в поле Gateway вписываем шлюз провайдера и жмем ОК.

установка шлюза по-умолчанию в mikrotik

Уже сейчас интернет должен заработать, но без указания DNS сервера обращаться можно только по прямым ip адресам. Например можно пропинговать ip адрес серверов гугла. Открываем New Terminal и проверяем.

ping dns сервера гугла

Теперь установим DNS сервер. Для этого идем в IP -> DNS, в поле Servers вводим адрес dns сервера провайдера. Если у вас их два, то нажав на треугольничек, направленной вершиной вниз, вы можете ввести еще одно значение. Обязательно ставите галочку напротив Allow Remote Requests.

установка dns сервера провайдера

На этом все, мы полностью установили настройки интернета провайдера. Можно проверить и пропинговать привычный адрес сайта.

ping ya.ru

На самом маршрутизаторе уже есть выход в интернет. На нам нужно его настроить для пользователей. Для этого продолжаем настройку mikrotik.

Настройка dhcp сервера

Для того, чтобы подключенные устройства могли получать сетевые настройки автоматически с роутера, на нем необходимо настроить DHCP сервер. Делается это не сложно, я сейчас по шагам все распишу. Идем в IP -> DHCP, переходим на вкладку DHCP и нажимаем DHCP Setup. Нам предлагают выбрать интерфейс, на котором будет работать сервер. Выбираем bridge1.

настройка dhcp сервера в микротик

Жмем next. Теперь нужно выбрать адресное пространство, из которого будут выдаваться ip адреса. По-умолчанию указана подсеть, в которую входит ip адрес роутера. На это подходит, оставляем значение по-умолчанию 192.168.9.0/24.

установка сети для dhcp

Дальше нужно указать адрес шлюза, который будут получать клиенты. Так как для них шлюзом будет выступать сам микротик, оставляем его адрес, который уже предложен.

установка шлюза для dhcp

Теперь нужно указать диапазон адресов, которые будут выдаваться клиентам. Если вам не принципиально и вы не знаете, зачем его нужно менять, то оставляйте как есть. Будут использованы все свободные адреса подсети.

список ip адресов для dhcp

На последнем этапе вводим адрес dns сервера, который будет выдаваться клиентам. Это может быть как сам микротик, так и dns сервер провайдера. Это не принципиально, но лучше указать сам роутер. Так что пишем туда локальный адрес 192.168.9.1.

dns сервер для dhcp

Следующий параметр оставляем по-умолчанию и жмем Next. На этом настройка dhcp сервера для локальной сети закончена.

Если мы сейчас проводом подключим любого клиента к mikrotik, то он получит сетевые настройки, но в интернет выйти не сможет. Не хватает еще одной важной настройки — NAT.

Настройка NAT

NAT это преобразование, или как еще говорят трансляция сетевых адресов. Я не буду рассказывать, что это такое, можно самим почитать в интернете. Все современные роутеры имеют функцию NAT для обеспечения доступа к интернету абонентов. Так что мы тоже настроим NAT в mikrotik.

Идем в раздел IP -> Firewall, открываем вкладку NAT и жмем плюсик. На вкладке General указываем только один параметр Out. Interface — ether5 (интерфейс подключения к провайдеру), все остальное не трогаем.

настройка nat в mikrotik

Переходим на вкладку Action, выбираем в выпадающем списке masquerade. Остальное не трогаем и жмем ОК.

установка masquerade

Все, NAT настроили. Теперь если подключить клиента проводом в один из портов, то он получит сетевые настройки по DHCP и будет иметь доступ к интернету. Нам осталось самая малость — настроить wifi для подключения беспроводных клиентов.

Настройка wifi точки доступа в mikrotik

Наш роутер почти готов к работе. Осталось только настроить wi fi точку доступа и можно про него забывать :). Настройка wifi в микротике заслуживает отдельной статьи. Там очень много нюансов и возможностей. Мы сейчас сделаем самую простую настройку, которая подойдет и полностью удовлетворит потребности домашнего wifi роутера. А для более глубоких познаний можно будет воспользоваться отдельным материалом на эту тему.

Первым делом активируем беспроводной интерфейс. По-умолчанию он выключен. Идем в раздел Wireless, выбираем wlan1 и жмем синюю галочку.

активация wlan интерфейса

Интерфейс из серого станет светлым. Переходим на вкладку Security profiles, два раза жмем мышкой на строчку с профилем default. В поле Mode выбираем dynamic keys. Ставим галочки напротив WPA PSK и WPA2 PSK и aes ccm. В поля WPA Pre-Shared Key и WPA2 Pre-Shares Key вводим пароль от будущей беспроводной сети. Я рекомендую использовать длинный пароль (не меньше 12-ти символов) с цифрами и спецсимволами. Да, вводить не очень удобно, но после того, как я сам без проблем брутил хэши простых паролей, я убедился, что лучше поставить сложный пароль, если не хочешь, чтобы к твоему wifi кто-то подключался.

настройка профиля безопасности

Сохраняем настройки. Возвращаемся на вкладку Interfaces и два раза жмем на wlan1, открываются настройки wifi интерфейса микротика. Переходим на вкладку Wireless. Выставляем настройки как у меня на скриншоте.

настройка wifi в mikrotik

Обращаю внимание на следующие настройки:

  • SSID — имя вашей беспроводной сети. Пишите то, что хочется.
  • Frequency — частота, соответствующая одному из 12-ти каналов. Самое первое значение это первый канал и так далее. Тут рекомендуется выбрать тот канал, который в вашем конкретном случае менее всего занят другими точками доступа. Если вы не знаете что это за каналы и как их проверить, то не обращайте внимания, может выбрать любое значение из списка.

Сохраняете настройки, нажимая ОК. Все, wifi  точка доступа на mikrotik настроена, можно проверять. Запускаете любое устройство, ищете вашу сеть, вводите пароль доступа и проверяете интернет. Все должно работать.

На этом основная настройка микротика закончена, но я рекомендую выполнить еще несколько настроек для удобства и безопасности.

Смена пароля администратора по-умолчанию

Как я уже писал ранее, пароль администратора по-умолчанию в mikrotik не задан, он пустой. Имя пользователя — admin. Давайте установим свой пароль для ограничения доступа посторонних к настройкам. Для этого идем в раздел System -> Users. Выбираем единственного пользователя admin, жмем правой кнопкой мыши и выбираем самый последний пункт password.

смена пароля по-умолчанию

В открывшемся окошке 2 раза вводим свой пароль и сохраняем его. Теперь, чтобы подключиться через winbox нужно будет указать не только пользователя admin, но и установленный пароль.

В свете последних взломов микротика, я настоятельно рекомендую не просто установить сложный пароль на административную учетную запись, а создать полностью новую, с именем пользователя отличным от admin. Для этого в списке пользователей, жмите плюсик и создавайте нового пользователя.

Добавление нового администратора в микротик

После этого, пользователя admin можно отключить.

Блокировка дефолтного admin

Настройка времени

Я рекомендую устанавливать правильное время и включать его автоматическую синхронизацию. Это может пригодиться, если вам понадобится посмотреть какие-нибудь логи и сопоставить время. Если оно не будет установлено, то это трудно сделать. Так что настроим его. Идем в System -> Clock, устанавливаем вручную время, дату и часовой пояс.

настройка времени

Сделаем так, чтобы время автоматически обновлялось через интернет. Идем в раздел System -> SNTP Client. Ставим галочку Enabled, в поле с адресами серверов вводим 193.171.23.163 и 85.114.26.194. Жмем Apply и наблюдаем результат синхронизации.

автообновление времени

Теперь часы роутера всегда будут иметь актуальное время.

На этом базовая настройка роутера mikrotik для домашнего пользования закончена. Можно устанавливать его на место и пользоваться.

Заключение

Я привел пример настройки микротика для домашнего пользователя в качестве замены другим популярным бюджетным роутерам. Для более сложной и осмысленной настройки можно воспользоваться моими статьями на эту тему:

  • Настройка firewall  — рекомендую для всех, кто чувствует в себе способность разобраться дальше и повысить безопасность своей сети. Это может быть полезно даже дома. Собственно, статья и написана на примере ситуации, которая ложилась у меня в квартире. С помощью фаервола я отсек паразитный траффик и избавил маршрутизатор от тормозов.
  • Запрет на доступ к сайтам — может быть актуально для тех, кто хочет, к примеру, ограничить доступ с компьютера ребенка к каким-то ресурсам в интернете.
  • Настройка двух каналов в интернет для резервирования — статья о том, как подключить двух провайдеров интернета и автоматически переключать доступ с одного на другого в случае проблем со связью у одного из них. Ситуация взята из реального примера загородного дома с двумя каналами в интернет.
  • Настройка бесшовного wifi роуминга — популярный материал на тему организации единой сети wifi, состоящей из множества точек доступа для покрытия большой площади. Это может быть актуально как домашним пользователям (загородный дом) так и корпоративным пользователям.
  • Настройка хранения логов на mikrotik — рассказ о том, как централизованно хранить логи с микротиков. Для дома это совершенно не актуально, а для корпоративного сектора, где важно хранить информацию о том, кто, куда и зачем.

Я заканчиваю свой рассказ. Буду рад любым замечания и комментариям на данную тему.

Видео

Онлайн курсы по Mikrotik

Если у вас есть желание научиться работать с роутерами микротик и стать специалистом в этой области, рекомендую пройти курсы по программе, основанной на информации из официального курса MikroTik Certified Network Associate. Помимо официальной программы, в курсах будут лабораторные работы, в которых вы на практике сможете проверить и закрепить полученные знания. Все подробности на сайте Курсы по ИТ. Стоимость обучения весьма демократична, хорошая возможность получить новые знания в актуальной на сегодняшний день предметной области.

Помогла статья? Есть возможность отблагодарить автора

127 комментариев

  1. добрый день , просмотрел кучу инструкций и не увидел альтернативной раздачи ип адресов внешним DHCP сервером для локальных клиентов — не WAN , ( стоит dfl210e c 2 ISP c с балансировкой и раздает ип адреса клиентам по разным VLAN ) , 2xMikrotik rb951G-2Hnd хочу использовать только для бесшовного wifi роуминга, нужно всего лишь настроить DHCP клиент для wifi клиентов … подскажите плз или ткните в ман . Спасибо

  2. Геннадий

    Автору огромное человеческое Спасибо за труд и предоставленную информацию! Благодарю!!! Очень полезная и информативная статья. Держу в закладках как справочник и при случаю скидываю ссылку тем, кто хочет изучить данный роутер подробнее. Еще раз Спасибо!

    • Zerox

      Спасибо за отзыв. Сейчас потихоньку готовлю материал по тонкой настройке wifi. У микротика много нюансов в этом плане. Есть черновики, наработки. Надо будет собрать все в статью.

      • Геннадий

        Буду ждать. Очень удобно изучать технологию с помощью специалистов, умеющих объяснять в доступной форме.

      • огромное спасибо за статью, но по вашим инструкциям не получается настроить микротик rb3011
        делаю все точно по инструкции а вот не выходит пишет

        если пинговать из самого роутера следующие:

        invalid value for argument address:
        invalid value of mac-address, mac address required
        invalid value for argument ipv6-address
        while resolving ip-address: could not get answer from dns server

        хотя 8.8.8.8 пингует норм DNS ввел не подскажите в чем причина?

        • Zerox

          dns все же по какой-то причине не работает, раз по ip пингует, а по имени сервера нет. Возможно сам dns настроен правильно, но фаервол блокирует запросы к внешним dns.

          • а из за прошивки может глючить?

          • а куда копать?

            • Zerox

              Первым делом обновить прошивку. Отключить все правила в firewall и проверить работу без него. Потом еще раз проверить настройки DNS. Если вроде все правильно, но не работает, сбросить все настройки в дефолт и настроить заново. Иногда это помогает 🙂

  3. Сергей

    здравствуйте. сейчас многие провайдеры перешли на стандарт IPoE. пользователи мучаются с перенастройкой, а надо лишь добавить одну галочку (или это лишь с моим провайдером?). не помешало бы добавить этот момент в статью, т.к. на других ресурсах информации по этому поводу ноль.
    Спасибо Вам большое.

  4. Александр

    Спасибо за статью. Настроил все по ней. MikroTik RB941-2nD. Провайдер проверяет по мак адресу устройство, изменил мас у Микротика ну нужный, вот только сразу при включении компа и роутера соеденения не происходит, не пингуется шлюз провайдера, помогает подключение напрямую от провайдера — соеденение пояляется, а потом уже перетыкиванием провода в роутер. Не могу понят почему так происходит?

  5. Александр

    Да, так не правильно?

    • Zerox

      Я честно говоря никогда так не делал и точно не могу сказать, к чему это приведет. Но раз возникает какая-та странная и непонятная ситуация, то она вполне может быть связана с этим. Я много раз менял mac на микротиках и подключал их к провайдерам. Тут нет никаких нюансов, все должно работать.

      • Аноним

        Сбросил я настройку мака на заводскую, зарегистрировал у провайдера новый мак, проблема исчезла. Скорее всего было как вы и предполагали из-за двух одинаковых мак адресов. Спасибо за подсказку!

      • Аноним

        Вообще у меня хоть IP и выдается по DHCP, но адрес все равно статический. Когда не было роутера и мне нужно было подсоединить нетбук, я просто прописывал вручную все настройки и соеденение было несмотря на другой мак.

        • Zerox

          Все правильно, значит привязка по маку в данном случае использовалась только для выдачи сетевых настроек. Если вы их сами знали и указали, то не удивительно, что все заработало. Это связано с организацией сети у провайдера. Не обязательно, что такой же трюк сработает с другим провайдером.

  6. Аноним

    Принес домой из офиса, сделал сброс настроек, подключил, обновил ПО-все заработало: интернет, вайфай. Больше ничего не требуется. Не всегда сложно=хорошо.

  7. Сергей

    Никак не получается подключить принтер по вайфай. Пароль корректен. Но после его подтверждения пишет, что соединение утеряно.

  8. У меня MIKROTIK RB951UI-2HND. Скорость провайдера 100 мегабит. Сейчас оператор предлагает скорость 1000 мегабит. Увеличится ли скорость данного роутера? Сейчас по спидтесту скорость загрузки 76 мегабит по воздуху. О, большое спасибо за статью, очень помогла!!!

    • Zerox

      Смысла нет переходить на этот тариф, так как в роутере нет гигабитных портов. Он все равно будет работать на скорости 100 мегабит. Нужно менять роутер на другой, с гигабитными портами.

  9. Здравствуйте, дошел по вашей инструкции до шага, где мы объединили порты в свитч. Приступаю к объединению в bridge, и после того как во вкладке ports выбираю either у меня получается не так как у Вас, напртив either 1 пишется не rootport а designated port плюс помимо этого появляются и either 2-4 порты напротив которых написано disabled port. Ладно, может у меня новая версия программы, перехожу к шагу настройки стат. IP, вы говорите network сам заполнится, а у меня требует его заполнить

  10. Андрей

    Добрый день.

    Как настроить микротик если мне надо чтобы микротик работал таким образом чтобы я смог заходить на него с внутренней сети т.е к примеру по адресу 192.168.4.100. Но при этом чтобы DHCP выдавался только клиентам которые будут подключаться по WiFi.
    Мне надо чтобы DHCP не выдавался в корпоративную сеть но при этом чтобы я смог заходить на микротик с компьютера из корпоративной сети и мониторить микротик по статическому IP.

    • Zerox

      А в чем проблема? Можно без проблем в dhcp сервере указать в качестве сетевого интерфейса только беспроводной. Он будет выдавать ip адреса только на него.

  11. Владислав

    Добрый день! Помогите настроить rb951 по скайпу за плату.
    У меня 2 штуки на данный момент: один будет использоваться как роутер+точка доступа, а второй просто как точка доступа (в последствии будет один pb951 + 2 обычных точки доступа).
    1. Их надо объединить в бесшовный роуминг.
    2. К одному порту роутера проводом будет подключен локальный сервер. Надо настроить, чтоб клиенты WiFi сети по внутреннему dns перенаправлялись на этот сервер, который будет отдавать свои страницы.
    3. Роутер должен быть подключен к интернету (это будет либо подключение через 3G юсб-модем, либо через другую WiFi которая раздает интернет). Провода с инетом нет.
    4. Все клиенты WiFi сети будут делиться на два вида: первые — имеют доступ только к локальной странице, которую раздает локальный сервер, вторые (в том числе сам локальный сервер) — могут иметь полноценный доступ в интернет.
    Мне нужно это сделать до 24.04.

  12. Фариза

    Добрый день. Помогите настроить микротик, оператор Билайн.

  13. Круто, как раз то что искал, спасибо за инструкцию

  14. Михаил

    Большое спасибо! Лаконично, с примерами… Все бы так писали 🙂
    У меня просьба — как настроить внешний доступ к Микротику ( для настроек) с конкретного IP_адреса(WAN)?

  15. Дмитрий

    Статья офигительна! Огромная помощь начинающим «роутероводам» и сочувствующим. 🙂 Не быстро, но уверенно настроил свой 951й — огромное спасибо автору!

  16. Константин

    А точно хорошая затея галочку напротив Allow Remote Requests ставить? Ведь тогда наш микротик вроде становится открытым для того, что б его использовали другие компьютеры извне в качестве DNS-сервера?

    • Zerox

      Кстати, хороший вопрос. Вообще, эта галочка ставится, чтобы в локальной сети компьютеры могли использовать микротик в качестве днс сервера. Станет ли он таковым для внешних клиентов, я не проверял, так как обычно настраиваю firewall и там закрываю доступ к dns снаружи. У меня есть пример правил в отдельной статье.

      • Константин

        Просто не все закроют роутер от запросов извне, а следовательно их роутеры могут стать участниками атак

        • Zerox

          Этот момент нужно отдельно проверить. Я не уверен, что он будет доступен извне.

          • Константин

            нам на mtcna что-то рассказывали о необходимости закрытия его. Подробностей к сожалению не помню

            • Алексей

              Allow Remote Requests — эту галку точно ставить не нужно. DNS Flood получить можно запросто. Потом разбирайся почему загрузка интернета у пользователя под 100%. А микрот при Вашей настройке будет перенаправлять запросы на DNS провайдера.

              • Zerox

                Если эту галку не ставить, то в dns запросы из локальной сети микротик не будет обслуживать. Придется пользователям по dhcp передавать dns провайдера или какие-то еще. Поэтому ставить ее все же надо, но закрыть 53 порт снаружи фаерволом. Об этом у меня рассказано в статье про настройку firewall.

                • Алексей

                  В микротике нет полноценного DNS сервера, поэтому, я считаю, что правильнее будет отдать через DHCP запрос на DNS провайдера, тем более провайдер может динамически передать свои DNS сервера в Dynamic Servers и тогда настройка в DHCP вообще не нужна.

                  • Zerox

                    Полноценный или нет, но он есть. Он умеет кешировать запросы и поддерживает статические записи, что достаточно для dns сервера без поддержки своих зон. Считаю, что лучше использовать его.

  17. К сожалению, ни слова о quick set, что заменяет некоторые ковыряния, и ка настраивать сетевую карту тоже не увидел.

    • Андрей

      Хорошо бы еще 4G модем включить в данную инструкцию. Пока не получается. Комбинирую несколько инструкций с других сайтов, но увы..

      • Zerox

        А что не так с 4g модемом? Там настраивать нечего. Просто втыкаешь его и он появляется еще одним сетевым интерфейсом. А дальше все точно так же настраивается, как тут описано. Я много раз использовал 4g модем с микротиком. На даче уже несколько лет работает связка.

        • Андрей

          настроил пункт за пунктом в соответствии с данной инструкцией, кроме пятого порта, но чего не так не пойму

  18. Валерий

    ГРОМАДНЕЙШЕЕ спасибо за статью!) Все именно то, что нужно и очень доступно. Наконец-то нашелся человек, который объяснил про мастер-порты, bridge между wifi и лан портами, и про NAT. Именно из-за последнего я полдня провозился. В инете куча статей, но все, как будто специально, опускают самые важные моменты.

  19. Александр

    А как сделать чтобы было два порта для провайдера? Чтобы можно было переключаться не переключая провода?

    • Zerox

      Это не тривиальная настройка, зависит от типов подключенных провайдеров. У меня нет статьи на эту тему.

  20. Станислав

    Добрый день. При первичной настройке есть возможность подключиться к роутеру через беспроводную сеть? На ноуте отсутствует возможность подключения через lan-кабель.

    • Zerox

      Да, есть. В первоначальной конфигурации, с которой приходит роутер от производителя? wifi уже настроен, причем без пароля. Но нельзя сбрасывать настройки в дефолт, как я советую, так как настройки wifi тоже пропадут и дальше только по проводу можно будет подключиться.

      • Станислав

        Спасибо. Но видимо придётся подключаться через usb-шную сетевую плату, почему-то при дефолтных настройках микротик в упор не хочет обрабатывать трафик с торрентов (и почти всех испробованных мной онлайн игр). На проброс портов реакции нет и есть подозрение, что что-то в настройках днс.

        • Станислав

          Внезапно всё заработало после сброса и включением/отключением автоматически получаемого от провайдера конфига.

  21. Дмитрий

    Добрый день! Подскажите, как настроить в качестве обычного коммутатора?

    • Валерий

      Статья ж об этом. Почитайте.

      • Дмитрий

        Первый микротик настроил по вашей инструкции. Второй надо подключить к первому микротику, где настроен DHCP, чтоб DHCP из первого микротика выдавал IP адреса на устройства второго микротика. Подскажите как это сделать.

  22. Отличные настройки для атаки по ДНС и раздачи интернета другим пользователям провайдера. Зачем вешать ДНС на микротик, когда DHCP может сразу отдавать адрес ДНС провайдера? В настройках NAT вместо ether1 лучше задать подсеть в src-address (к примеру 192.168.88.0/24). Плюс не лишнее отключить доступ, которым вы не пользуетесь в ip>services.

  23. Светлана

    А цифровое тв как можно подключить? mikrotik rb952ui-5ac2nd

  24. Александр

    Добрый день) Есть один интереснейший вопрос, настраивал по вашей инструкции (сама настройка девайса и файрвола) , а так же на настройках заводских проверял. Интернет через PPPoe (Велком, бывший Атлант Телеком) с выделенным IP, Mikrotik RB951Ui-2hnd, v.6.41.2 , работает все отлично, но несколько раз в день, доходило до 10 раз, происходит сбой, Mikrotik перестает пинговаться, соответственно пропадает интернет. Информации нигде не нашел по данному вопросу. И роутер новый купил такой же, все тоже самое. Самое интересное что у знакомого на интернете от МТС настройки интернета по DHCP получает, работает все отлично. Подскажите, в чем может быть проблема? звонил в тех поддержку Велкома, сказали что разрыва соединения с провайдером не происходит в момент пропадания пинга, и что проблемы на моей стороне.

    • Zerox

      Вариантов может быть масса. Если есть возможность, настройте отправку логов на отдельный syslog сервер. Так можно будет хотя бы увидеть последние логи перед зависанием. Возможно там будет что-то полезное.

      Еще приходит на ум firewall. Возможно кто-то заваливает запросами какой-то сервис на микротике, который смотрит в интернет открытым портом. Закройте все внешние подключения к микротику.

      • Александр

        Спасибо что откликнулись. Буду настраивать отправку логов на syslog сервер. В понедельник с утра отключу все внешние соединения. Но сегодня заметил, когда в локальной сети пропал интернет, выкинуло из winbox, модем перестал пинговаться, мой ноут был по WiFi подключен, и на нем все хорошо работало и пинги и winbox и интернет. Получается что из за чего то перестают работать порты. После микротика у меня стоит DLink староватый, может он или коллизия в сети происходит где то? Может быть из за этого?

  25. Здравствуйте! Спасибо за статью, все понятно написано хотя бы))) А если требуется на нем настроить видеонаблюдение как быть?

    • Zerox

      А какое отношение имеет видеонаблюдение к роутеру микротик?

      • камеры к нему подключены) впрочем я уже разобралась. Единственное что в моей версии прошивки по какой-то причине не было опции назначения порту мастера, пришлось идти окольным путем и в быстрой настройке пометить все лан порты как слэйв. так себе решение, но может комут поможет…. либо если есть получше варианты — хотелось бы услышать т к не последний раз с ними сталкиваться буду)))

        • В новых версиях прошивки убрали это функцию, можно объединить порты через bridge.

  26. Татьяна

    Добрый день, если сможете помочь мне) роутер настроен, все ок, но подключили ip-телефонию от другого провайдера, есть адрес ip телефона, disable для сервиса под именем sip с портами 5060, 5061 отключали. не помогло
    просят прописать порта еще 10000-20000, но как это осуществить? не получается

  27. Аноним

    Добрый день! да,
    все верно

  28. Максим

    Здравствуйте. Помогите пожалуйста решить проблему. Точкой доступа выступает Микротик routerboard RB951G-2HnD. Есть умная лампа от Xiaomi, работает с помощью приложения Mi Home по Wi-Fi, лампа настраивается, включается, выключается , регулируется- все замечательно, но до отключения лампы от сети питания (220В), больше лампа подключаться не хочет, пока не сделаешь сброс лампы на заводские настройки, дальше она опять видится и настаивается. Что интересно, с данной точкой доступа работает несколько устройств от xiaomi и таких проблем нет. Думал проблема с лампой, т.е. с вай фаем, попробовал две другие точки доступа, в качестве одной был сматфон, в качестве другой D-Link DAP-1155, с обоими точками доступа лампа работает без проблем, питание отключаем, лампа пропадает из списка подключенных устройств, включаем питание лампа подключается. В чем засада с микротиком я так и не понял, почему настроенная лампа не хочет подключаться именно к микротику для меня большая тайна.

    • Zerox

      Так трудно что-то посоветовать. Я сталкивался с похожими проблемами, когда, к примеру, устройство apple не могло корректно работать с точкой доступа mikrotik. То отключается, то сильно тормозит. Сталкивался неоднократно, проходило само. В то время это было связано каким-то образом с режимом энергосбережения, который использовало устройство и не поддерживал mikrotik. После какого-то обновления все стало нормально. Может и здесь есть какой-то нюанс.

  29. Сергей

    Хелп плиз..подскажите какой юсб свисток приобрести.. так как купил вот такой роутер https://mstream.com.ua/hap-ac-mikrotik.html и понимаю что не справляюсь с ним..купил 3ж свисток от киевстар а оно то ли не определяет свисток толи я криворук 🙂

    • Zerox

      Трудно сказать, какой именно будет работать. Я нигде не видел готового списка. Я сам уже несколько лет с микротиком использую 4g модем, который может принимать следующие названия модели: Huawei E3372 / E3372h / 827F / M150-2. Это все одно и то же и оно работает с микротиками. Никаких настроек не надо. Просто втыкаешь в usb разъем роутера, и он определяет устройство как lte. Просто появляется еще один интерфейс в списке. Все очень просто.

  30. Владимир

    Можно ли внести обновления в статью? (в связи с упразднением Master Port)

    • Zerox

      Запланировал обновление статьи. Надо все по микротику обновлять, много времени прошло.

  31. Евгений

    Статья прекрасная!
    А нет ли возможности через микротик организовать резервный канал интернета?

  32. Валерий

    В последних обновлениях RouterOS убрали возможность указывать мастер-порт. Надо обновлять статью)

  33. Добрый день
    Делал все по вышей инструкции, но интернет так и не получилось настроить, перепробовал кучу разных мануалов по настройке, но интернет так и не пришёл
    Повторюсь, идеально все сделал по вашей инструкций, за исключением одной вещи — при добавлении портов, у меня привязалось ещё и остальные езернет порты

  34. Всеволод

    пожалуйста помогите, после сброса заводских настроек, роутер перестали видеть устройства. В чем может быть проблема и как ее устранить?

  35. Подскажите пожалуйста как настроить VPN на RB951G-2HnD?

    • Zerox

      У меня нет готовой инструкции, но в целом настроить, к примеру, pptp сервер не представляется никакой сложности. Все делается за 10 минут. Инструкций в интернете много.

  36. Есть задача заблокировать доступ к интернету у всех пользователей кроме 5 комп., при этом локальная сеть и почтовые клиенты должны работать. Доступ к интренету открывается в обед на 1 час и после работы. Оборудование Mikrotik Route OS 6.42.5. Есть какие нибудь решения в этот вопросе?

    • Zerox

      Решение есть во встроенном firewall. Но у вас специфичные требования и готовых рецептов вряд ли найдете. Надо разбираться самому, но ничего сложного и принципиально невыполнимого в вашей задаче нету.

  37. Александр

    Приобрел роутер Mikrotik hAP ac lite для сельской местности. Будет использоваться для раздачи интернета, получаемого поочередно :
    1. смартфоном Samsung c включенной Мобильной точкой доступа и галочкой «USB-модем» — с подключением телефона к роутеру USB кабелем.
    2. USB модем Мегафон 150-2.
    Переключение связано с ограничением так называемого «безлимитного» интернета в дневные часы, когда до конца месяца остается немного, «дневной» интернет закончился, а на телефонах наоборот, интернета не потраченного много.
    Как настраивать USB модем Мегафон 150-2 инструкции нашел.
    Можете подсказать как настраивать интернет через мобильный телефон/смартфон?

    • Zerox

      Не уверен, что микротик определит телефон в режиме модема. Я никогда не пробовал так делать и не видел, чтобы кто-то так делал. Если не заработает по usb, то можно на телефоне создать точку доступа wifi, подключить микротик к ней и раздавать. Правда смысла особо нет, можно напрямую с телефона раздавать в таком случае.

      • Александр

        Благодарю за оперативный ответ.
        Смысл в том, что Mikrotik стоит на чердаке (ближе к принимающей антенне, которая установлена высоко над домом, и соединена с USB-модемом). С него по витой паре сигнал раскидывается по стационарным компам + ноутбукам, которые находятся в других постройках.
        Чтобы телефон ловил интернет, его тоже приходится уносить на чердак. Но тогда подключиться по вай-фаю можно только ноутбуками, причем приходится находиться в том же доме.

        А есть ли где-нибудь инструкция как правильно настроить Mikrotik, чтобы интернет брал по Wi-Fi и по Wi-Fi же раздавал? Или так нельзя?

        • Zerox

          Так 100% можно я делал и проверял. Инфу нашел в гугле по запросам «mikrotik репитер» или «микротик подключиться к другому wifi». Что-то в этом духе, но нашел быстро, настраивать там не сложно. Скажу сразу, что wifi sid на микротике лучше сделать отличным от sid на телефоне. Я сначала делал одинаковые, но не удобно. Не сразу понятно, куда подключилось устройство, к микротику или телефону напрямую.

  38. Добрый день. Нужен совет, если можете подскажите пожалуста. Mikrotik RB951G-2HnD, все что нужно настроил, тырнет работает, но…
    В доме несколько андроид устройств и бывает нужда кидать файлы между ними туда-сюда. Со старым роутером это делалось по FTP,
    удобно и быстро. А с Mikrotik номер не проходит. На андроид в качестве порта для FTP указан порт 2121, или можно произвольный,
    выше 1035, (21 нельзя, нужен рут). И затык. С андроида на ноут зайти можно, с ноута на ноут можно, с ноута на андроид никак, с анд-
    роида на андроид — никак. Везде подняты FTP сервера, и со старым роутером я мог кидатся файлами с любой железки на любую.
    А сейчас не пойму чего ему надо. Из правил файервола и NAT на Mikrotik есть только это:
    /ip firewall filter
    add action=accept chain=input in-interface=lte1
    /ip firewall nat
    add action=masquerade chain=srcnat src-address=192.168.0.0/24 src-address-list=»»
    add action=masquerade chain=srcnat out-interface=lte1

    Чего ему надо-то?

    • Zerox

      Вряд ли это как-то с микротиком связано. По крайней мере, я не придумаю, как. Отключите firewall вообще в локальной сети и проверяйте.

    • а вы точно все порты им пробросили? микротик к этому очень требователен + там во вкладке сервисов бывают часто дефолтные надстройки которые некоторые похождения блокируют дабы якобы обезопасить пользователя. в них бывает тоже проблема и требуется их просто все удалить

  39. Добрый день. Настраивал по вашей инструкции. Ещё добавил PPTP клиента и прописал соответствующее правило для подсети.
    Роутер сам все видит и все пингует, но компьютеры внутри сети не видят ничего дальше роутера (ни WAN, ни сеть за PPTP).
    Я так понимаю, дело в настройках Firewall, потому что заводская настройка прописывает определенные правила и в Filter Rules, и в Mangle. А по итогам вашей инструкции ничего в этих вкладках нет.

  40. огромное СПАСИБО автору статьи!
    Всё настроилось, хоть и пришлось подумать, что тоже не плохо.

  41. Александр

    Можно ли внести обновления в статью в связи с упразднением Master Port? Хотя бы в двух словах — только раздел, касающийся Master Port.

  42. Александр

    Спасибо. А примерно, когда ждать обновление? Купил два RB951G, заодно хочу их объединить в бесшовный Wi-Fiроуминг.

  43. Добрый день. Настроил по Вашей статье, легко быстро. Спасибо большое за полную инфу для новичков. Стала еще задача контролировать появление конкретных клиентов в зоне вайфай с уведомлением на е-мейл. Пытался настроить через netwatch, но загвоздка появилась с отправкой на электронку. Даже тестовое письмо не отправляется при настройке. Ящик на gmail. Может что подскажете?

    • Zerox

      Как клиентов идентифицируете? По МАК адресу? Я бы просто логи микротика отправлял бы куда-нибудь на сервер и там уже анализировал, настраивал уведомление и т.д. Например, через zabbix бы вел учет и оповещения.

  44. Александр

    Добрый вечеx, за статью поклон) если при настройке что то забываю, то всегда обращаюсь к вашей статье)

    но я с нестандартной ситуацией. может кто сталкивался или мысли какие подкинет.?

    Есть два микротика. у каждого внешний ip. между ними настроен vpn через l2tp. связь равнозначная. один ip используется для почтового сервера. возникла надобность развернуть еще один почтовый сервер для тестовов. тут то и пригодился второй ip. кстати почтовый сервер настраивал по вашей статье IREMAIL. ЗА ЭТО ТОЖЕ СПАСИБО))) и возникла проблема. пробросить порт для почтового сервера из другой подсети. Обдумываю два варианта. Либо проброс через впн, либо проброс через два роутера. внешний IP адрес и почтовый сервер находятся по разные стороны VPN. пробовал различные правила и маршрутизацию прописывать , ничего не идет. единственное начинает заводится веб морда. к примеру когда внешний ip в браузере прописываешь 214.211.221.112 то SOGo начинает загружаться https://214.211.221.112/SOGo , но пишет превышен интервал ожидания

    • Zerox

      С таким пробросом много нюансов. Я так делал когда-то и отказался. Не помню точно, почему не осилил, но у меня чуть сложнее структура была. В целом, решаемо, но точно подсказать, что делать, не могу. Надо рисовать схему сети и вникать, где что пробросить, какой маршрут добавить и т.д. Потом дебажить с tcpdump, если что-то не работает и пакет теряется.

      • Александр

        а проброс через 2 nat может получится? я пробовал делать проброс с первого внешнего ip на второй внешний на первом роутере, а на втором обычный проброс на нужный ip локальной сети. начинает заводится и превышен интервал времени ожидания открытия страницы

        • Zerox

          Это значит, что не работает проброс. Важно не только в одну сторону прокинуть пакеты, надо проследить, чтобы обратно они по тому же пути пошли.

          • Александр

            все пошло. проброс через 2 микротика. настройки перепроверил, была опечатка в порте https. а так одно правило на первом микротике и одно правило на втором микротике.

  45. Отличная статья. Разжёванно для младенцев.
    Но есть один вопрос.
    Прошивка 6.44beta28 (Testing) в Interfaces — ether2 (в остальных тоже) — отсутствует поле Master Port.

  46. Здравствуйте, можно ли настроить RB951Ui-2HnD таким образом чтоб на него можно было подключаться удаленно с другого города?

    • Конечно можно, но не нужно, в целях безопасности. Лучше сделать проброс на какой нибудь комп/ноут из той сети, где микротик. И с него спокойно заходить на роутер.

      • Zerox

        А потом через этот проброс пролезет виндовый червь 🙂 Лучше ограничивать доступ к микротику по ip. Это надежнее, чем проброс. Конечно, если есть возможность использовать список статичных ip для доступа.

        • Не пролезет, следить надо))) ну конечно же список лучше, если своя статика есть.

  47. Работаю с mikrotik более 5 лет и за подобные статьи хочется убивать…ну блин добавьте хотя-бы базовый firewall

    /ip firewall filter
    add chain=input connection-state=established,related action=accept
    add chain=input proto=icmp action=accept
    add chain=input in-interface=bridge1 action=accept
    add chain=input in-interface=ether5 src-address-list=allow-wan action=accept
    add chain=forward in-interface=bridge1 out-interface=ether5 connection-state=established,new action=accept
    add chain=forward in-interface=ether5 out-interface=bridge1 connection-state=established,related action=accept

    все, теперь никто не будет использовать ваш dns для усиления ddos и через nat не проломится к вам в сеть. и если обнаружатся новые баги в winbox из глобальной сети вас никто не взломает

    • Zerox

      Про firewall отдельная статья есть.

      • fw — это часть базовой настройки, в отдельной статье там есть про что написать, но базовый fw должен быть в базовой настройке.

    • упс совсем забыл про
      add chain=input action=drop
      add chain=forward action=drop
      в конце…

      • Zerox

        А я такой посмотрел, думаю, вот грамотей, пришел с советами, а сам оставил решето из своих правил 🙂

  48. Валерий

    Спасибо за качественную статью!) Ждем следующую — о защите.

  49. Напишите пожалуйста статью, на тему балансировки, распределения нагрузки, и резервирования двух и более каналов интернета на одном устройстве MikroTik. Да, в интернете есть такая информация. Но хотелось бы узнать, как и каким образом реализуете это Вы, в своей практике, на своих устройствах.

    • Zerox

      К сожалению, у меня уже нет практического опыта в этой теме. Могу только на стендах что-то из любопытства собрать. Я практически не занимаюсь сетевыми вопросами последние пару лет. Остались старые микротики, которые давно настраивал и поддерживаю по привычке. Перешел полностью на администрирование серверов, причем преимущественно в web тематике.

  50. Валерий

    О спасибочки! Недавно тоже покрутился с Mikrotik! После dlink и Zyxel конечно все по другому…
    Но когда все поймешь, то уже кажется все просто!
    Очень гибкие настройки. Специально купил hAP lite? чтобы поближе познакомится..
    А в компании у Вас ,что нибудь стоит от Mirotika?

    • Zerox

      У меня нет компании. У меня есть ИП и удаленная работа с заказчиками. Но микротик обычно советую, если считаю его уместным в данном случае.

Добавить комментарий

Ваш e-mail не будет опубликован.

Нажимая кнопку "Отправить комментарий" Я даю согласие на обработку персональных данных.